PDA

View Full Version : pause exit issue with mame



srk15372
04-05-2016, 04:18 AM
Hi, I have a problem using hyperpause.
On my new installation windows 8.1, using joytokey, I have all configured to works with hyperspin and all is fine using two arcade stick on usb. But as soon as I use my third controller xbox one wireless with adapter, I encounter a strange issue on mame.
I can enter on menu Pause (hyperpause) but when exit to return to mame ( esc key configured on controller) , I loose control of mame whitch stay in first screen and heard hyperspin move behind using control. (I feel that it escape two time on a single press)
I donít have this issue when this third controller (xbox one) is off.
I try to change the esc key by another key but it still the same.
Any idea ? Thank you.

bleasby
04-05-2016, 05:50 PM
What happens when you launch the game with RocketLauncherUI instead of HyperSpin?
Try to test if by letting HyperSpin closed and using only RocketLauncher the bug happens so you could pin point what is causing.
If the bug doesn't happen on this case, the problem is on something related with HyperSpin that is stealing the focus.

Test also if the bug happens when disabling the keymapper.
Maybe joytokey is the one stealing the focus.

It is almost impossible to help something so specific to your configuration with the amount of info available.

srk15372
04-06-2016, 02:56 AM
ok thank you, I will do these tests today and let you inform about progress and describe more infos of my device
thanks

srk15372
04-06-2016, 08:08 AM
Hi, I have made some tests.
the issue is the same using only rocketlauncherUI without hyperspin.
When I turn off the keymapper joytokey all seems Ok with keyboard and xbxox one controller ON.
It's seems that joytokey and wireless xbox one controller are the issue.
but I couldn't knows what other test to do. it's very annoying because all my other previous installations doesn't reproduce this.
I bought this ELITE xbox one controller just for use HYPERSPIN.
The 2nd strange thing is that I have configure RETROARCH for severals device and I could activate and exit hyperpause without any
issue with the xbox controller ON.
regards

brolly
04-06-2016, 09:25 AM
Settings -> Main Settings -> Desktop -> Hide Frontend
Try setting this to true.

srk15372
04-06-2016, 01:30 PM
I try this without success unfortunaly.
i 'don't understand what happen.