PDA

View Full Version : SSF Saturn emulator pause black screen



tmills
04-11-2016, 07:16 AM
I'm having trouble with SSF and RL/Hyper Pause, it just goes to black screen then the emulator closes. Does anyone have RL/Hyperpause working with SSF?

i have tried changing my exit emulator key and that makes no difference. i use my controller to enter pause by holding the start button for 3 seconds and it works fine on all other emulators so far.

djvj
04-18-2016, 02:44 PM
Is your emu in fullscreen or windowed mode? That makes a big difference in how RL handles many emus when it comes time to pause it.

Cannasteve
05-16-2016, 12:11 PM
Hello i have the same problem in both fullscreen and windowed mode, and in windowed when i push the key for start pause (for close the black screen), the emulator window go to fullscreen.

Any solutions?

djvj
05-17-2016, 01:47 AM
I fixed the going fullscreen on pause exit, but bleasby will have to figure out why Pause doesn't show as everything appears to be correct:

To fix the fullscreen issue, replace the Restore label with this:

RestoreEmu:
emuPrimaryWindow.Activate()
If (Fullscreen = 1)
{
TimerUtils.Sleep(500)
KeyUtils.SetKeyDelay("",100) ; change only pressDuration
KeyUtils.Send("!{Enter}")
}
Return

bleasby
05-18-2016, 01:39 PM
The crippled directX implementation on SFF is as buggy as hell. I don't remember if I ever added pause support for it.
Anyway, here are my findings:

1) Disable vsync.
SFF just crashes if you try to minimize it to the task bar if you have vsync enabled. Therefore, if that is the case for you, disable the VSynchWaitWindow and VSynchWaitFullscreen option on the module options.

2) Do not use NumpaddAdd as your pause key.
NumpadAdd is hardcoded on the emu to resize its window. Do not use it as the RocketLauncher pause key as it can change the game size while pausing the game.
By the way, you shouldn't use any other SFF hardcoded key for similar reasons.

These changes should be enough to make pause work if you are using bezel or windowed mode.
By the way, I tested this with a completely empty Halt and Restore emu labels.
I cannot test if these steps are enough to make pause work on fullscreen also as the emu just crashes without any error report if I try to run it on that mode, making impossible to launch any fullscreen game on my computer.

If you guys can test these findings on your setups, and see if it makes any difference for the fullscreen run, these points should be added to the SSF module notes.

Tenebro
04-26-2017, 03:49 PM
The crippled directX implementation on SFF is as buggy as hell. I don't remember if I ever added pause support for it.
Anyway, here are my findings:

1) Disable vsync.
SFF just crashes if you try to minimize it to the task bar if you have vsync enabled. Therefore, if that is the case for you, disable the VSynchWaitWindow and VSynchWaitFullscreen option on the module options.

2) Do not use NumpaddAdd as your pause key.
NumpadAdd is hardcoded on the emu to resize its window. Do not use it as the RocketLauncher pause key as it can change the game size while pausing the game.
By the way, you shouldn't use any other SFF hardcoded key for similar reasons.

These changes should be enough to make pause work if you are using bezel or windowed mode.
By the way, I tested this with a completely empty Halt and Restore emu labels.
I cannot test if these steps are enough to make pause work on fullscreen also as the emu just crashes without any error report if I try to run it on that mode, making impossible to launch any fullscreen game on my computer.

If you guys can test these findings on your setups, and see if it makes any difference for the fullscreen run, these points should be added to the SSF module notes.

Greetings. Encountered exactly the same problem. The above did not help. Can there be other options for fixing the error? Thank you.