• Section Navigation

  • RocketLauncher v1.0 Release!

    We are proud to announce the release of RocketLauncher v1.0!


    In this release, all instances of HyperLaunch have been replaced with RocketLauncher. Also what was once HyperLaunchHQ is now known as RocketLauncherUI and HyperPause is now known as Pause. As you can imagine, this was a very intensive change. Changing all references from one name to another takes a very long time to do it right. Certainly never want to do that again.


    In case you haven't realized, the url here is now www.rlauncher.com. The old domain will still bring you here for awhile until I decide to expire it. So update your bookmarks.


    With this release, most of you will be happy that GIT is no more. You no longer need to be bothered installing another application to use RocketLauncher. I thank you all for putting up with it for the time until we could develop a proper method to get you updates. RocketLauncherUI now has a built-in updater that brolly did an excellent job with. Each time you launch RocketLauncherUI, and you are online, RocketLauncherUI will inform you if there are any new changes you need to download. All updates are handled internal to RocketLauncherUI. GIT will be taken down very shortly.


    So going forward, please use RL when talking about RocketLauncher and RLUI when talking about RocketLauncherUI. If you use HL, we will assume you are talking about an older version, which is not supported here.


    To ease the transition from HyperLaunch v3.x to RocketLauncher, I created a Transition tool to do all the work for you. You will also find the links to the initial upgrade pack there as well. Please see this guide on how to use them. It's only a few clicks and you will be all set to use RocketLauncher:
    http://www.rlauncher.com/wiki/index....m_HyperLaunch3


    I'd also like to thank Warham and Marxkemp from IRC that helped me test this new release.


    Please see below for the changes in this release:

    General updates:

    • Many modules that did not have "Hide Emulator" support now do
    • DaemonTools is now known as VirtualDrive so future support can be added to other applications in the future
    • BetaBrite_Params setting changed default to "usb {AUTO}%FRONTEND%" which will replace FRONTEND with the plugin name so it can be used across any FE
    • Fixed a bug when ServoStik_Enabled & Hide_Cursor were set per-game, would take affect for other games
    • Fixed direct launching system selection not showing due to new system xml structure changes
    • Fixed bug in direct launch where it would show values that were not system names in drop down box
    • Exit_Script_Key default value changed from Q+S to PageUp+PageDown
    • Fade_Layer_4_W (Animated Image - Image Width) default changed from 128 to 200 because it was making the Rating image too narrow on default Fade
    • Fade_Layer_4_X (Animated Image - Animation X) default changed from 1792|952 to 1715|952 so the animated image would be on screen by default
    • Fade_Layer_4_Y (Animated Image - Animation Y) default changed from 891|1596 to 720|1596 so the animated image would be on screen by default
    • SaveProperties changed so it does not cause delays and only writes to HDD once.
    • Added systemDbName as it comes from the Front End in case media needs to be loaded from that name when an alternate systen name is mapped
    • PacDrive and DXwnd file checks moved into their functions and only verify existance when those features are used.
    • Added ability to trigger ScriptError w/o closing the module which can let the module handle errors and exiting properly from its environment
    • Now automatically copies example inis over to their working versions when CheckFile() is used to check their existence. Note, this is not used on example module inis because those inis are never required.





    Updated Plugins:

    • HyperLaunchHQ.plugin (now known as RocketLauncherUI.plugin)



    New Modules:

    • mGBA initial release



    Updated Modules:

    • aae to 2.0.4
    • applewin to 1.6
    • arculator to 1.1
    • beebem to 1.0.3
    • bgb to 2.0.2, also support for Multiplayer_Menu (ghutch92)
    • bizhawk to 2.0.3
    • casual games to 2.0.4
    • ccs64 to 2.0.3
    • cdiemu to 2.0.2
    • cpce to 2.0.3
    • daphne singe to 2.0.6
    • demul 0.5.8 to 2.0.5, also Gaelco and Sega Hikaru now supported. Per-game memcard support. New settings OpaqueMod, TransMod, videomode. Fix file encoding automatically. Some VMU visibility fixes
    • desmume to 2.0.6
    • dfend to 2.0.1
    • dolphin to 2.0.7, also netplay (MultiPlayer) support updated wiimote function for dolphinbar. Netplay support will also take into account "_netplay" named inis if you need tweaked settings only for netplay. RLProfilePath now requires (RL) in the name instead of (HL). Module now takes into account portable.txt to determine what settings to use. Updated notes.
    • dosbox to 2.0.2
    • dwjukebox to 2.0.1
    • dxwnd to 2.0.5
    • emugaki to 2.0.1
    • epsxe to 2.1.0
    • epv-1000 to 2.0.2
    • esc-3000 to 2.0.1
    • escv to 2.0.1
    • final burn alpha to 2.0.2
    • flash player projector to 2.0.2
    • fourdo to 2.0.3
    • freedo to 2.0.3
    • freezesms to 2.0.2
    • fs-uae to 2.0.2, also many more changes and settings
    • fusion to 2.1.1
    • gamecom to 2.0.3, also added i18n support
    • handy to 2.0.2
    • hatari to 2.0.1, also many new additions and settings by wahoobrian
    • higan to 2.0.4
    • magic engine to 2.0.2
    • makaron to 2.0.3
    • mame to 2.1.8, also added IniPath, GLSL, & VerticalRotationMode settings
    • mednafen to 2.1.2, also added Nintendo BS-X Satellaview & Nintendo Sufami Turbo and fixed stretch
    • mess to 2.2.6, also added Applied Technology MicroBee support
    • mfme to 2.0.6
    • mupen64plus to 2.0.4
    • nestopia to 2.0.4
    • nintendulator to 2.0.2
    • nulldc to 2.0.6, also per game memory cards support
    • ootake to 2.0.2
    • openbor to 2.0.2
    • parajve to 2.0.3
    • pclauncher to 2.1.6
    • pcsx2 to 2.1.2, also DTOverride setting renamed to VDOverride and VD_CDVD_Plugin renamed to VD_CDVD_Plugin
    • pcsxr to 2.0.6
    • pheonix to 2.0.4
    • picodrive to 2.0.3
    • pinball arcade to 2.0.2, also updated emu version to 1.37.8 with some new tables (marxkemp)
    • pinball fx2 to 2.0.6
    • playguy to 2.0.2
    • ppsspp to 2.0.3
    • project64 to 2.0.2, also added EmuVersion setting by rfancella
    • project tempest to 2.0.3
    • psxfin to to 2.0.4
    • retroarch to 2.2.7, also fixed bug with LibRetro_DUCK & LibRetro_EBK. Added systems Sega Mark III, Sega Mega Drive 32X and Nintendo SuFami Turbo (newoski), Tiger Game.com (nomisholman)
    • scummvm to 2.0.9
    • sega model 2 emulator to 2.0.8
    • snes9x to 2.0.2, also added Nintendo Satellaview support, and ControlType setting to set your controller type per game
    • ssf to 2.1.1
    • steem sse to 2.0.2, also many new additions and settings by wahoobrian
    • stella to 2.0.3
    • turbo engine 16 to 2.0.1
    • unz to 2.0.2
    • virtual aquarius to 2.0.2
    • winape to 2.0.3
    • winuae to 2.1.4, also huge update by turranius
    • xm6 to 2.0.3, also some new stretch settings
    • xmillennium to 2.0.2
    • yabause to 2.0.1
    • xebra to 2.0.2 also i18n support & setting memcard path



    Updated Libs:

    • Bezel updated to v1.1.0
    • Fade updated to v1.1.0
    • Fade Animations updated to v1.1.2
    • HyperPause renamed to Pause and updated to v1.0.9
    • HyperPause init renamed to Pause Init and updated to v1.0.2
    • Keymapper updated to v1.1.1
    • Keymapper Init updated to v1.0.3
    • MultiGame updated to v1.0.7
    • MultiPlayer updated to v1.0.5
    • Password updated to v1.0.1
    • Rom Mapping Launch Menu updated to v1.0.4
    • Shared updated to v1.2.4
    • Statistics updated to v1.0.3
    • XHotkey updated to v1.0.3
    • User Fade Animations



    Updated Module Extensions

    • RocketLauncher.dll
    • Origin updated to v1.0.2
    • Steam updated to v1.0.2



    Updated Daemon:

    • HyperLaunchDaemon renamed to RocketLauncherDaemon
    This article was originally published in forum thread: RocketLauncher v1.0 Release! started by djvj View original post
    Comments 111 Comments
    1. djvj's Avatar
      djvj -
      Yes it was tedious! Upgrade to the HS 1.4 beta and you don't need to change your HS inis at all.
    1. aorin1's Avatar
      aorin1 -
      Hope I didn't miss any info about it, but after the latest update, which is 1.0.0.2 (RLUI), systems that were disabled using HyperTOOls now are displayed in the left list.
      I'll try switching back to 1.0.0.1, hope it's not the wrong thread to ask for help about new releases.

      Thanks for all your effort in RL
    1. jeremy0203's Avatar
      jeremy0203 -
      Quote Originally Posted by aorin1 View Post
      Hope I didn't miss any info about it, but after the latest update, which is 1.0.0.2 (RLUI), systems that were disabled using HyperTOOls now are displayed in the left list.
      I'll try switching back to 1.0.0.1, hope it's not the wrong thread to ask for help about new releases.

      Thanks for all your effort in RL
      Yes, I mentioned this in a thread some days ago. It is because the new version of hypert00ls uses the new enabled entry in the xml file. RLUI does not yet utilize this when deciding which systems to show. Brolly said he will be working on it eventually as he is the one that requested that be added to HS.
    1. Inquisitom's Avatar
      Inquisitom -
      The latest version of HyperT00ls lets you choose if you want to keep disabled systems in the xml or not ... this avoids having unneeded systems in RLUI.
    1. brolly's Avatar
      brolly -
      This has nothing to do with the RLUI update since nothing changed regarding that, this is related with hypert00ls as jeremy stated they seem to be using the new enabled tag on the XML while before they commented out the XML entries. The first one isn't supported by RLUI yet, will be eventually.
    1. Deadvacahead's Avatar
      Deadvacahead -
      As of yesterday I have been unable to update my RocketLauncher. When I launch RocketLauncherUI i get "Couldn't connect to server, please check if you have internet connectivity" error message. I am on RocketLauncherUI version 1.0.0.2. Is there something I need to do in order to get the update working again or is this a widespread server side problem? Thanks for any help!

      Update: Ok, just like five minutes after posting this I'm able to update again. I didn't change anything to do anything differently. How strange. Temporary issue fixed by the twilight zone I guess.
    1. paulmichel21's Avatar
      paulmichel21 -
      i install windows 8.1 and rocketlaucher.dll asks me need 3.5 NetFramework to work and it has become impossible for me to install this net3.5 in Windows 8.1 ..... there any way is to rocketlauncher works with NetFramework 4.5.2 ?
      thanks
    1. tonesmalone's Avatar
      tonesmalone -
      Quote Originally Posted by paulmichel21 View Post
      i install windows 8.1 and rocketlaucher.dll asks me need 3.5 NetFramework to work and it has become impossible for me to install this net3.5 in Windows 8.1 ..... there any way is to rocketlauncher works with NetFramework 4.5.2 ?
      thanks
      This is totally possible. It's in Control Panel --> Programs & Features --> Windows Features.

      New window comes up, tick .net 3.5, then ok. It will then download and install.

      Or follow this guide: https://msdn.microsoft.com/en-us/lib...v=vs.110).aspx
    1. paulmichel21's Avatar
      paulmichel21 -
      thanks i work hard to resolve this but lose and lose and lose... maybe windows 8.1 dont like me... jeje
    1. paulmichel21's Avatar
      paulmichel21 -
      thanks i reinstall windows 8, and fix too
      the problem is language i uninstall spanish and works fine...

      Quote Originally Posted by tonesmalone View Post
      This is totally possible. It's in Control Panel --> Programs & Features --> Windows Features.

      New window comes up, tick .net 3.5, then ok. It will then download and install.

      Or follow this guide: https://msdn.microsoft.com/en-us/lib...v=vs.110).aspx
    1. gamersmith's Avatar
      gamersmith -
      hey..going well and this game is truly a masterpiece.