Thread: Module SNES9X 1.54.1

Results 1 to 8 of 8
  1. Collapse Details
    Module SNES9X 1.54.1 
    #1
    Member
    MainSecondary
    Join Date
    Jun 2015
    Posts
    64
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site
    Question
    Hello,

    I was taking a look at Super Nintendo with this emulator (I updated to the lastest version) and I think that it maybe needs a module update because I don't see any window title change loading a Super Nintendo rom or a Satellaview one (I think that they fixed/removed that) and RocketLauncher doesn't notice that it opens or close because of this (I think).

    Thanks.
     

  2. Collapse Details
    Re: Module SNES9X 1.54.1 
    #2
    RocketLauncher Developer
    djvj's Avatar
    MainSecondary
    Join Date
    Apr 2014
    Location
    Long Island
    Posts
    6,292
    Tested 1.54.1 and current module works fine.
    "Computer games don't affect kids; I mean if Pac-Man affected us as kids, we'd all be running around in darkened rooms, munching magic pills and listening to repetitive electronic music."

    If you appreciate our work, please support the site by clicking the Donate button at the top of the page.
     

  3. Collapse Details
    Re: Module SNES9X 1.54.1 
    #3
    Member ChrisKant's Avatar
    MainSecondary
    Join Date
    Nov 2014
    Posts
    50
    the SNES9X Modul has to change a slightly to work perfect with BS-X Roms, else there is a Window Class Error

    Bildschirmfoto 2017-02-15 um 19.27.59.png

    Line 26... from (new WindowTitle("Snes9x-sx2",... to Snes9x",

    this should be updated in the official Rocketlauncher

    there should also a little chance for the system Bandai SUfami Turbo... I always thought that this system was called Nintendo Sufami Turbo, like in the Mednafen Modul
     

  4. Collapse Details
    Re: Module SNES9X 1.54.1 
    #4
    RocketLauncher Developer
    djvj's Avatar
    MainSecondary
    Join Date
    Apr 2014
    Location
    Long Island
    Posts
    6,292
    Thanks for the info, I'll update the module for the next push. Are you sure that 1.54 works the same as 1.53 with BS-X? I noticed when I boot with 1.53 and the sx-2 exe, it boots into the BS-X bios, but on 1.54 it just goes directly into the game. The 1.53 sx-2 release is an entirely different build, not the normal 1.53 download.

    I made the module detection a little more intelligent and will now work with both 1.53 and 1.54 and sx2 or normal exes.

    The hardware however was made by Bandai, for Nintendo hardware. It was not made by Nintendo, so the correct name is Bandai Sufami Turbo.

    I'll also update the system name in the mednafen module.
    Last edited by djvj ; 02-15-2017 at 08:04 PM.
    "Computer games don't affect kids; I mean if Pac-Man affected us as kids, we'd all be running around in darkened rooms, munching magic pills and listening to repetitive electronic music."

    If you appreciate our work, please support the site by clicking the Donate button at the top of the page.
     

  5. Collapse Details
    Re: Module SNES9X 1.54.1 
    #5
    Junior Member
    MainSecondary
    Join Date
    Apr 2019
    Posts
    3
    Hi,

    I just updated the same emulator to the latest v1.6, it seems that this module hasn't been updated since this thread since i'm seeing the same error and module shows its for 1.53. Can you help?
     

  6. Collapse Details
    Re: Module SNES9X 1.54.1 
    #6
    Junior Member
    MainSecondary
    Join Date
    May 2016
    Posts
    21
    Module is not compatible with Snes9x 1.60 could you please give us a tip so we could edit a working custom version of the module?
    Thank you very much.
     

  7. Collapse Details
    Re: Module SNES9X 1.54.1 
    #7
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,102
    Quote Originally Posted by Icemac View Post
    Module is not compatible with Snes9x 1.60 could you please give us a tip so we could edit a working custom version of the module?
    Thank you very much.
    This module should work.

    Since you asked for a tip, the search function on the forum will help you find relevant updates. The thread where I posted the updated module would've been the first result from searching "snes9x".
     

  8. Collapse Details
    Re: Module SNES9X 1.54.1 
    #8
    Junior Member
    MainSecondary
    Join Date
    May 2016
    Posts
    21
    Thank you very much agent47 and excuse me for my redundant question, my forum search was inaccurate. You're module version is perfectly working with Snes9x 1.60.
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •