Thread: Exit Emulator issues

Results 1 to 4 of 4
  1. Collapse Details
    Exit Emulator issues 
    #1
    Junior Member
    MainSecondary
    Join Date
    Jun 2017
    Posts
    3
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site
    I'm a newbie to this world, but I have a grasp of the basics... I'm having an irritating issue on my machine that is running Rocketlauncher and Hyperspin:
    Somehow I have set the exit emulator command to be "player 1 start + player 2 start" on accident.
    I just installed new buttons to have a simple one button system exit and one button game exit - I went into rocket launcher and changed the "exit emulator key" to match the button I installed. I removed the combo key that was previously used (P1 coin + P2 start).
    I went separately into MAME and made sure that only the commands in rocket launcher were set for exit game... but when I hit P1 start + P2 start it still exits games in MAME, NAOMI, and DAPHNE.
    Am I missing something obvious here? It clearly is a global setting, but I can't seem to find where it is hidden.
    I didn't see anything obvious on HyperHQ - but that is where I was able to set the single button to exit the system (mame, Naomi, etc).

    Anyone able to help a newbie that thinks he is going insane?
     

  2. Collapse Details
    Re: Exit Emulator issues 
    #2
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,340
    If you select Global from the system list and edit the Exit Emulator Key on the Settings -> Main Settings tab that will set the exit key for all systems. However, if you were to select MAME from the system list and change that option it would override the global one. If you want every system to use the same one then set it under the Global system and make sure each system is set to use_global.

    Any controls you set in HyperHQ only affect navigating through the HS wheels, nothing pertaining to in game controls or exiting the emulators.
     

  3. Collapse Details
    Re: Exit Emulator issues 
    #3
    Junior Member
    MainSecondary
    Join Date
    Jun 2017
    Posts
    3
    Quote Originally Posted by agent47 View Post
    If you select Global from the system list and edit the Exit Emulator Key on the Settings -> Main Settings tab that will set the exit key for all systems. However, if you were to select MAME from the system list and change that option it would override the global one. If you want every system to use the same one then set it under the Global system and make sure each system is set to use_global.

    Any controls you set in HyperHQ only affect navigating through the HS wheels, nothing pertaining to in game controls or exiting the emulators.
    Thank you, that confirms that what I've done should have made it so that hitting the button I assigned (P1B8 on my ipac ultimate I/o) should be the only thing that makes it exit an emulator.
    Somehow hitting the 2 start buttons together still makes it exit an emulator.

    Is there somewhere else that commands like that can be assigned that I'm just not seeing?
     

  4. Collapse Details
    Exit Emulator issues 
    #4
    Junior Member
    MainSecondary
    Join Date
    Jun 2017
    Posts
    3
    Figured it out...
    The I-PAC has a default setting that uses the P1 start button as a "shift" button?and the P2 Start button acts as "Esc" when it is shifted... so it makes it exit an emulator!
    That is all nice if you never play 2 player games where both players might need to hit their start buttons at the same time! Easy to disable in WinIPAC - now it is working as expected.

    Not sure how to edit the thread title to say "solved"... but problem solved
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •