Thanks Thanks:  0

Thread: Custom XML is giving me headaches :|

Results 1 to 4 of 4
  1. Collapse Details
    Custom XML is giving me headaches :| 
    #1
    Junior Member
    MainSecondary
    Join Date
    Nov 2016
    Posts
    5
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site
    I created an XML called "Best-Of.xml", i've put many games and I specified all the <exe>Atari 2600</exe> for example. For an unknown reason, it works with MAME games, some other games but when I try to launch an Atari 2600 game I get "No default_Emulator found in ...\Settings\Best-Of\Emulators.ini. Please set one so RL knows what module to use... Of course I don't have a default emulator set because it's using many emulators in the XML. When I check the RL log, it says the same message I just retyped, than ExitScript - Started...

    What I don't get is why does it work when I specify MAME for some other games and also a few other emulators but not Atari 2600 or Atari 5200... I'm really confused and I tried looking for why this is happening for many hours but can't find it 😐

    Thank's in advance, must be a small error somewhere I'm just missing in reviewing and reviewing.
     

  2. Collapse Details
    Re: Custom XML is giving me headaches :| 
    #2
    Senior Member
    MainSecondary
    Join Date
    Jul 2015
    Posts
    127
    AFAIK you cannot specify an emulator in the xml. If anything from mame works, then mame is set as the default emu in the ini.

    You can now set an "alternate emulator" for each game in your xml that is not a mame game. Do this from inside RLUI.

    Sent from my SM-A520W using Tapatalk
     

  3. Collapse Details
    Re: Custom XML is giving me headaches :| 
    #3
    Junior Member
    MainSecondary
    Join Date
    Nov 2016
    Posts
    5
    Quote Originally Posted by Spawk View Post
    AFAIK you cannot specify an emulator in the xml. If anything from mame works, then mame is set as the default emu in the ini.

    You can now set an "alternate emulator" for each game in your xml that is not a mame game. Do this from inside RLUI.

    Sent from my SM-A520W using Tapatalk
    Found the problem... What was happening, I had two Decathlon The, (USA), one for Atari 2600 and one for Atari 5200 so it was stating no default emulator. Same thing for another game... But it's probably better as you said to do it in RL
     

  4. Collapse Details
    Custom XML is giving me headaches :| 
    #4
    Member drewjbx's Avatar
    MainSecondary
    Join Date
    Jun 2015
    Posts
    92
    Create your custom xml from existing ones.. copy and paste the game tags you want. Then RLUI add that custom xml as a system... if most games are Mame... make Mame default emulator and you will have to add the rest under alternative emulators. There might be tools to do custom playlists, I think ninja2bseen has some tutorials on YouTube for this. But I know this method works although pretty tedious. Then you will have to link up all your artwork with symbolic links to wheels, themes, create new rl fade media folders if you want that.... in general you will have duplicates of media, pain in the arse.




    Sent from my iPhone using Tapatalk
    Last edited by drewjbx ; 01-08-2019 at 04:25 PM.
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •