Thanks Thanks:  0

Thread: Retroarch slowdown after activating pause

Results 1 to 8 of 8
  1. Collapse Details
    Retroarch slowdown after activating pause 
    #1
    Junior Member
    MainSecondary
    Join Date
    Jan 2019
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site
    Hi,

    I'm having trouble with Pause slowing down my emulation in Retroarch. My frame rate drops from 60 down to 38 something and the audio gets all choppy and video is stuttering. This only happens after pause has been active. Pause will activate and close as it's supposed to but after the emulation is unusable.

    I am using the Nestopia core and have tried other NES cores and that doesn't make a difference. I have played with some retroarch settings and changing to threaded video under the video settings seems to allow it to work but the video after that is not smooth like it is normally.

    If I kill the RocketLauncher process the emulation returns to normal so it must be something that RL is doing to it.

    Switching from full screen to windowed and back fixes it briefly but the problem returns shortly after going back to full screen. It runs fine windowed though.

    I searched the RetroArch module for the HaltEMU and RestoreEMU (I think it was) but they are not found so I can't even try the settings mentioned in other forum posts about switching out of full screen before pause and back into full screen after. Tried it manually and at first it worked but after playing for a while (around 30 secs to a min) the audio and video started acting up again. To be clear if I never activate pause I never have a/v issues.

    The game I'm playing to test is Super Mario Bros 3. I have all the media and manuals from EmuMovies loaded for the pause screen but it really doesn't make a difference what I do on the pause screen. If it gets activated and closed the problem occurs.

    Any help would be appreciated!
    Thanks,
    Rich
    Last edited by rwebb616 ; 01-28-2019 at 01:12 AM.
     

  2. Collapse Details
    Re: Retroarch slowdown after activating pause 
    #2
    Junior Member
    MainSecondary
    Join Date
    Jan 2019
    Posts
    9
    Well I guess Rocket Launcher is not going to be part of my cabinet unfortunately. No help for days and it's unusable for me so back to just plain Attract Mode. I like the concept and it's great software but if I can't make it work reliably then I can't use it. Thanks though

    Rich.
     

  3. Collapse Details
    Re: Retroarch slowdown after activating pause 
    #3
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,044
    Not having a response in 2 days is normal since it relies on users to help and not everyone visits the forum multiple times a day.

    It also doesn't help that you didn't include a troubleshooting log like the wiki specifies or an RA log or any settings. So even if someone wanted to help they have no info to go off of. Given the number of RA users this is likely some sort of settings issue in RL or RA as I don't recall seeing anyone mention this issue before.
     

  4. Collapse Details
    Re: Retroarch slowdown after activating pause 
    #4
    Junior Member
    MainSecondary
    Join Date
    Jan 2019
    Posts
    9
    I just tried it in a different system and I don't have the same problem. I'm planning on building up a Ryzen 2200g based system with the built-in Vega graphics. I'm guessing it will do much better on that system. Only complaint on this other system is that the pause interface is very laggy - I have to hold the stick for a second before it moves etc. Guess I have to weigh the pros and cons. Is it better to have a slow interface but the ability to view the manual/moves and stuff or is it better not to have it at all and have everything be snappy.

    I know not everyone visits the forums regularly but I was basing my response on the 60 some views it had with no response. I could certainly post the logs but I didn't see anything that looked like it could be relevant. Perhaps turning up the log level would produce more information but the system seems to be running OK, just kills the speed of the emulator once pause is activated.
     

  5. Collapse Details
    Re: Retroarch slowdown after activating pause 
    #5
    Member neonrage's Avatar
    MainSecondary
    Join Date
    Jun 2015
    Posts
    62
    I started using RetroArch 1.7.5, upgraded from 1.2.x and noticed the same behavior after pause. I found that exiting pause was triggering slow-mode in RetroArch (half framerate). If you hit your hotkey for slow-mode, it would resume full speed. Since I have no need for slow-mode, I was able to fix this by changing the value in my Retroarch.cfg file for slowmotion_ratio from the default 3.0 to 0. Saved the cfg, and now when I exit pause, no slow downs. Alternatively you could unbind in your retroarch.cfg the key to trigger slow-mode. Either way, that will fix your issues exiting pause.
     

  6. Collapse Details
    Re: Retroarch slowdown after activating pause 
    #6
    Junior Member
    MainSecondary
    Join Date
    Jan 2019
    Posts
    9
    Quote Originally Posted by neonrage View Post
    I started using RetroArch 1.7.5, upgraded from 1.2.x and noticed the same behavior after pause. I found that exiting pause was triggering slow-mode in RetroArch (half framerate). If you hit your hotkey for slow-mode, it would resume full speed. Since I have no need for slow-mode, I was able to fix this by changing the value in my Retroarch.cfg file for slowmotion_ratio from the default 3.0 to 0. Saved the cfg, and now when I exit pause, no slow downs. Alternatively you could unbind in your retroarch.cfg the key to trigger slow-mode. Either way, that will fix your issues exiting pause.
    Thanks Neonrage. I tested this and that doesn't appear to be the issue. Now it's just doing random slow downs with no pattern to it other than it doesn't start until after pause is activated and released. I actually paused it 2 or 3 times with no slowdown and then it just randomly slowed down while I was playing the game. Seems to be no rhyme or reason. I'm also running Attract-Mode as my front-end so maybe that has something to do with it. I am not having any of these issues on another system though.

    Rich
     

  7. Collapse Details
    Re: Retroarch slowdown after activating pause 
    #7
    Member neonrage's Avatar
    MainSecondary
    Join Date
    Jun 2015
    Posts
    62
    Does your system have a system specific .cfg file? If so you'd have to disable slow mode in that not in the default.
     

  8. Collapse Details
    Re: Retroarch slowdown after activating pause 
    #8
    Junior Member
    MainSecondary
    Join Date
    Jan 2019
    Posts
    9
    What I did was set up a key to enable/disable slow mode and used it when the issue was occurring and it made no difference. The slowness was present regardless of the setting.

    I do not have a system specific .cfg file that I know of.

    Rich
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •