Thanks Thanks:  0

Thread: RL not loading "alternate" Core configured for RetroArch (Playstation)

Results 1 to 5 of 5

Hybrid View

  1. Collapse Details
    RL not loading "alternate" Core configured for RetroArch (Playstation) 
    #1
    Junior Member
    MainSecondary
    Join Date
    Aug 2017
    Posts
    4
    Hi guys, need some help from the masters as I have a very specific need for which I couldn't find an answer anywhere:

    I'm using RetroArch for Playstation emulation and the PCSX_ReARMed as the default Core but there's a known issue to run the game "Driver - You're the Wheelman" (which crashes at some point after loading).

    This game can be played perfectly using Bettle_PSX Core (which I can execute in RetroArch directly).

    The point is, it's not possible in RLUI to specify a different core per game in the "Alternate Emulator" tab in this case, as the system and emulator themselves are the same (PS/RA).

    Failed Workarounds: I created another "Emulator" entry, mapping RA executable to a renamed copy of the Retroarch module (both files needed: the .ahk and the other) and assigned it in the Alt. Emulator tab for the game. The module is configured with Bettle_PSX as the default core, but for some reason, when I launch the game in Hyperspin, it adopts the default RA emulator config/Core, not the Alternate RA emulator config/Alt Core just created.
    (tried both: Global emu and System specific emu and had the same results)

    Thanks in advance for your help!

    main system specs:
    RocketLauncher: latest version
    Hyperspin: latest version
    RetroArch 1.7.6
    Intel I5 running Windows 10
     

  2. Collapse Details
    Re: RL not loading "alternate" Core configured for RetroArch (Playstation) 
    #2
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,102
    You can set the core on a per game basis in the module settings.
     

  3. Collapse Details
    Re: RL not loading "alternate" Core configured for RetroArch (Playstation) 
    #3
    Junior Member
    MainSecondary
    Join Date
    Aug 2017
    Posts
    4
    Thanks agent47 and sorry to insist, but I cannot find such option. When I go into module settings (either global or system based config), only a few fields are available and I cannot see anything related to the Core.
    Not sure if my original post is not clear, but I believed by adding a new Emulator + using a new Module (copied from RetroArch and which has the specific Bettle_PSX Core assigned) and assigning all that to the game in the "Alternative Emu" tab should do the job.

    Could you please give me some more details on what I'm missing to have this fixed?

    Many thanks for the help and for all the contributions to the emulation community!
     

  4. Collapse Details
    Re: RL not loading "alternate" Core configured for RetroArch (Playstation) 
    #4
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,102
    Global Module Settings -> Rom Settings tab. Select a game with the green plus icon and set the core.
     

  5. Collapse Details
    Re: RL not loading "alternate" Core configured for RetroArch (Playstation) 
    #5
    Junior Member
    MainSecondary
    Join Date
    Aug 2017
    Posts
    4
    Perfect, many thanks agent47!!!
    The way I was navigating was taking me somewhere else and I was never able to find this specific setting.
    Working fine now!
     

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •