Thanks Thanks:  0

Thread: Mame game not launching

Results 1 to 10 of 10
  1. Collapse Details
    Mame game not launching 
    #1
    Junior Member
    MainSecondary
    Join Date
    Aug 2016
    Posts
    7
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site
    Hello,

    I've set everything in RL for the MAME 0.216 version but when launch a game in Hyperspin, in place of laucnhing the game, I get this screen (see attachment 1.jpg).
    When I click on exit, I get MAME (see attachment 2.jpg) but the game is not launched.

    Has anyone an idea?

    Thanks and regards,
    Attached Images Attached Images
    • File Type: jpg 1.jpg (350.1 KB, 8 views)
    • File Type: jpg 2.jpg (424.2 KB, 6 views)
     

  2. Collapse Details
    Re: Mame game not launching 
    #2
    Senior Member tonesmalone's Avatar
    MainSecondary
    Join Date
    Jun 2014
    Posts
    758
    Yeah MAME is launching without a game specified so itís just loading to its default screen.

    We need a troubleshooting log to see whatís happening.


    Sent from my iPhone using Tapatalk Pro
     

  3. Collapse Details
    Re: Mame game not launching 
    #3
    Junior Member
    MainSecondary
    Join Date
    Aug 2016
    Posts
    7
    Thanks for the answer.

    What log do you need? MAME log, Hyperspin log or RL log?
     

  4. Collapse Details
    Re: Mame game not launching 
    #4
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,257
    RL log, instructions here.
     

  5. Collapse Details
    Re: Mame game not launching 
    #5
    Junior Member
    MainSecondary
    Join Date
    Aug 2016
    Posts
    7
    Thanks,

    I'll try that.

    Meanwhile, I've tried the following:

    If I select system MAME / Module / Module 2.3.7 and I ask to launch the emulator, it succeeds.

    So it's rather the game that cannot be launched correctly.

    I've downloaded the 2.3.10 ahk version but it's in red with those 2 errors:

    Invalid CRC, module might have been tampered

    Invalid ISD CRC, ISD file might have been tampered...
    Last edited by doohan ; 02-07-2020 at 01:19 PM.
     

  6. Collapse Details
    Re: Mame game not launching 
    #6
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,257
    That info doesn't mean much without logs.

    Those errors/warnings will not affect the module working. It just means whoever edited it didn't remove the hashes like they should've.
     

  7. Collapse Details
    Re: Mame game not launching 
    #7
    Junior Member
    MainSecondary
    Join Date
    Aug 2016
    Posts
    7
    Thanks to the MAME64 0218 version, MAME seems to launch correctly now but it’s not launching the game.

    5.jpg

    By asking a log, I get this :

    6.jpg

    Think the problem is in the last 4 lines mentionning 7z. Seems to be a problem with the path or name of the roms…

    If anyone has an idea, it will be greatful.

    ��
    Last edited by doohan ; 02-08-2020 at 08:05 AM.
     

  8. Collapse Details
    Re: Mame game not launching 
    #8
    Junior Member
    MainSecondary
    Join Date
    Aug 2016
    Posts
    7
    I made a lot of progress.

    I've downloaded and installed RL on my PC and updated it.

    I set the same settings, same module and same emulator that on my cab and well, games are launched.

    The only difference I see is that the module is interpreted as "2.3.10" on my cab

    9.jpg

    and as 2.3.10 on my pc.

    7.png

    This is the warning on the log on myc pc to compare with the one of my cab but it worked.

    8.png

    As I cannot update my cab because in a separate room without connexion, which files should I copy from my pc on my cab to make run the same way?



    Thank you,**
     

  9. Collapse Details
    Re: Mame game not launching 
    #9
    Super Moderator
    agent47's Avatar
    MainSecondary
    Join Date
    Jan 2016
    Posts
    1,257
    When posting logs make sure they're in code tags in a single post. If it won't let you because of size limits paste the log contents on pastebin.com and link to that. Posting them like you did kills the formatting making them harder to read and they were automoderated because the site thought you were spamming.

    In those logs you have several settings incorrect. 7z should always be false for any arcade system and Match Extension should basically never be enabled for any system outside of a few specific cases.

    Your first screenshot shows that the module header isn't being parsed correctly because you're using an older version of RLUI. To get rid of the CRC errors use the module here. Whoever uploaded the one you're using didn't edit it properly.

    All the warnings errors are normal in your 3rd screenshot. The last one says you have enabled cheats and don't have a cheat file so either disable cheats in the module settings or place the file where it specifies.

    RL/RLUI is portable so download a fresh install on your net connected pc, update it and transfer the whole folder over to your cab or you can transfer your existing updated one.
     

  10. Collapse Details
    Re: Mame game not launching 
    #10
    Junior Member
    MainSecondary
    Join Date
    Aug 2016
    Posts
    7
    Thanks a lot agent47.

    I've updated my cab with the extrenal HDD files updated from RL but still without result.
    I downloaded your version of the MAME.ahk + set the 7z files to FALSE and now the games are running.
    on MAME 0218.
    Last edited by doohan ; 02-08-2020 at 06:57 PM.
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •